Photo by Melody
Congratulations to all our photo contest participants! Check out the winning photos here. We will have the 2015 calendars available to order from Zazzle soon.

PlantFiles How-to's: TUBEROSES

Communities > Forums > PlantFiles How-to's
bookmark
Forum: PlantFiles How-to'sReplies: 1, Views: 25
Add to Bookmarks
-
AuthorContent
sanhla
Tucson, AZ

November 7, 2011
3:25 PM

Post #8880588

MY TUBEROSES DID NOT BLOOM THE SECOND AND THIRD YEAR. THE PLANTS LOOKED HEALTHY. I AM IN TUCSON, AZ . ZONE 10, SUMMER TEMPERATUREWS 100F PLUS. PLEASE ADVISE OR SUGGEST.


sanhla
Jamper
Sugarland, TX
(Zone 9a)

November 3, 2014
4:59 PM

Post #9969113

Very rarely a question about tube roses with Wsome fragrance. They consistently come up in Fwbruary - cold does not bother them. I think they do very well in shed. I have had success in clay soil wet and under ahade.


Post a reply to this thread:

From:

Your message:

You may upload up to 5 images. Press CTRL to select more than one image file.


Upload Images to your reply

    -



    Other PlantFiles How-to's Threads you might be interested in:

    SubjectThread StarterRepliesLast Post
    Why don't you follow the rules of nomenclature? Terry 1 May 31, 2008 3:40 PM
    Taxonomy changes coming in the PDB Terry 41 Oct 20, 2007 2:03 AM
    How do I search for what is reported to grow well near me? ceallachg 12 Aug 29, 2008 11:27 PM
    Meet your PlantFiles Editors Terry 44 Aug 26, 2010 1:35 AM
    Royalty lilac bigcityal 7 Aug 8, 2007 11:26 PM


    We recommend Firefox
    Overwhelmed? There's a lot to see here. Try starting at our homepage.

    [ Home | About | Advertise | Media Kit | Mission | Featured Companies | Submit an Article | Terms of Use | Tour | Rules | Privacy Policy | Contact Us ]

    Back to the top

    Copyright © 2000-2014 Dave's Garden, an Internet Brands company. All Rights Reserved.
     

    Hope for America