Photo by Melody

Plant Identification: SOLVED: Azalea with spots and losing leaves

Communities > Forums > Plant Identification
Forum: Plant IdentificationReplies: 3, Views: 26
Add to Bookmarks
Houston, TX

January 22, 2013
9:56 AM

Post #9393667

I am trying to find out what is wrong with my Azelas. This started mid last summer, actually when I adjusted my sprinkler system, which gave the Azelas more water, not for sure if that had anything to do with it.

Thumbnail by DESIGNPRO   Thumbnail by DESIGNPRO
Click an image for an enlarged view.

Port Richey, FL
(Zone 9a)

January 22, 2013
10:39 AM

Post #9393718

I am not sure excatly, but looks like a fungus of some sort.


Beautiful, BC
(Zone 9b)

January 22, 2013
10:44 AM

Post #9393722

root rot?
Houston, TX

January 22, 2013
11:23 AM

Post #9393757

Thanks yall! That helped.

You cannot post until you register and login.

Other Plant Identification Threads you might be interested in:

SubjectThread StarterRepliesLast Post
SOLVED: Help with identification of this shrub dave 91 Feb 3, 2015 2:40 PM
SOLVED: Can Anyone Help Gayl 9 Jun 23, 2014 4:57 AM
SOLVED: help identify herb seeds????? dignbloom 6 Nov 4, 2010 8:08 PM
SOLVED: Mystery perennial dave 22 Nov 3, 2014 6:02 AM
SOLVED: Name my aloe??? tom1953 21 Jul 15, 2012 1:32 PM

Overwhelmed? There's a lot to see here. Try starting at our homepage.

[ Home | About | Advertise | Media Kit | Mission | Featured Companies | Terms of Use | Tour | Rules | Privacy Policy | Cookie Policy | Contact Us ]

Back to the top

Copyright © 2000-2015 Dave's Garden, an Internet Brands company. All Rights Reserved.

Hope for America