Photo by Melody
Congratulations to all our photo contest participants! Check out the winning photos here. We will have the 2015 calendars available to order from Zazzle soon.

Mums and Asters: Mums won't bloom!

Communities > Forums > Mums and Asters
bookmark
Forum: Mums and AstersReplies: 6, Views: 128
Add to Bookmarks
-
AuthorContent
texasgarden
Dallas, TX
(Zone 8a)

October 10, 2004
1:22 AM

Post #1087408

All I can think is it's the container. I have always gotten them to grow in the ground just fine. I put these in a galvanized pot with holes drilled through the bottom. Used Miracle Grow potting mix and fertilized with bone meal. I dead headed, and there are green buds but they won't bloom and the plants won't grow. What's up?! Jamie
Shirley1md
Ellicott City, MD
(Zone 7a)

October 10, 2004
2:59 AM

Post #1087524

When did you "dead head" them??? Rule of thumb...don't cut back Mums after July 4th or you will sacrifice their blooms. They also need to be growing in full sun. Keepin' my fingers crossed for you next year!
texasgarden
Dallas, TX
(Zone 8a)

October 10, 2004
3:36 AM

Post #1087577

Sorry Shirley- I wasn't clear. I just planted them a few weeks ago in this container so they are brand new plants. By dead head I just mean I pulled off the fading blooms- I didn't cut them down or anything. Now there they sit with buds that will NOT open. :(
Shirley1md
Ellicott City, MD
(Zone 7a)

October 10, 2004
3:45 PM

Post #1088060

Hmm, they are in full sun, right? Maybe since you are in a warmer zone than me, they will bloom in late October/early November...fingers & toes crossed!
texasgarden
Dallas, TX
(Zone 8a)

October 10, 2004
4:08 PM

Post #1088092

Oh, based on everyone elses, the should be blooming. Though my friend has a few big, older mums in the ground that come up each year and hers are not blooming yet. These were in bloom when I bought them, then as those blooms faded I just pinched them off. This is what I have always done and had no problems with new blooms coming up. Maybe it's because of all the rain we have been getting... I just don't know! But yep, they are in full sun. :)
dstartz
Deep South Texas, TX
(Zone 9a)

October 10, 2004
4:48 PM

Post #1088146

I have multiple pots of mums as well as some in the ground and although they all had buds for several weeks only one has started to bloom.

I also have several new pots of mums that I recently dead headed and they are starting to form new buds.

I thought they needed some extended cool snaps to make them want to bloom...
texasgarden
Dallas, TX
(Zone 8a)

October 11, 2004
12:32 AM

Post #1088774

Maybe that's it. Glad to know it isn't just me! Guess we'll wait and see what happens. It's been an odd year anyway with this weather!

You cannot post until you register, login and subscribe.


Other Mums and Asters Threads you might be interested in:

SubjectThread StarterRepliesLast Post
Mum's the Word... SILLYLILY 18 Nov 23, 2009 6:47 PM
Aster Blue Ribbon Sue_WA 8 Nov 27, 2009 11:54 PM
Pinching back mums...... orange_knickers 11 Aug 17, 2007 5:16 AM
Cutting back fall Asters? rainy_jane 27 Aug 30, 2007 3:26 PM
How many others have lost their mum? leaflady 40 Jul 9, 2007 1:56 PM


We recommend Firefox
Overwhelmed? There's a lot to see here. Try starting at our homepage.

[ Home | About | Advertise | Media Kit | Mission | Featured Companies | Submit an Article | Terms of Use | Tour | Rules | Privacy Policy | Contact Us ]

Back to the top

Copyright © 2000-2014 Dave's Garden, an Internet Brands company. All Rights Reserved.
 

Hope for America