Tucson, AZ(Zone 9a)

I noticed that while most every plant I enter in my journal automatically links to it's "Detailed Page" here at Dave's, my entry for Purple Heart (Tradescantia pallida) does not. Why is that? I double checked my spelling.

Murfreesboro, TN(Zone 7a)

Jen, I think it's probably because we have two cultivars listed in PlantFiles - 'Purple Heart' and 'Purewell Giant': http://davesgarden.com/pf/search.php?search_text=Tradescantia+pallida&submit=Search

Your journal entry doesn't indicate the cultivar, so the system can't match it to either PF entry.

Tucson, AZ(Zone 9a)

That fixed it, thanks!!

Murfreesboro, TN(Zone 7a)

Glad I could help ;o)

Tucson, AZ(Zone 9a)

OK, I've got another one...
http://davesgarden.com/journal/j/viewentry/47851/
This Echinopsis does not list a species name. The cultivar is 'Epic.'
So why won't my journal page give a link?

Murfreesboro, TN(Zone 7a)

Do you have the cultivar name (Epic) listed in your journal, or is it listed as the common name? (I can't tell from the "external view" I have.)

Tucson, AZ(Zone 9a)

I have it as both the common name and as the cultivar.
The journal page with the list of plants: http://davesgarden.com/journal/j/vbc/TucsonJen/22315/

Murfreesboro, TN(Zone 7a)

Hmmm. I know this has been kind of a buggy area for matching. I hope at some point Dave can set the logic to something like:

1) If Genus and species fields match and cultivar is blank, match to PF entry for same;

2) If Genus and cultivar match (and species is blank), match to PF entry for same;

3) If Genus, species and cultivar match, match to PF entry for same.

I think that would take the ambiguity out of the matching process, but then again, there may be some scenarios I haven't thought of ;o)

Tucson, AZ(Zone 9a)

Thanks, Terry. I thought it was another error of mine. :p

Lenexa, KS(Zone 6a)

I think right now the logic is that if you show a Cultivar in your Journal that you must match the Genus and species names to get a link. I don't get a link to any of my Hemerocallis entries because the PF entries have no species listed. So even though I've matched exactly what is in the PF (Genus & Cultivar) I still don't get the link because a species match is required if you have a cultivar name listed.

I agree that Terry's proposed "hit" logic is the way to go whenever this ToDo gets up on Dave's active list of projects.

Post a Reply to this Thread

Please or register to post.

Upload Images to your reply

    You may upload up to 5 images
    BACK TO TOP