Help! Amaryllis - leaves only

Waterloo, ON(Zone 5a)

My only experience with growing amaryllis is in pots, indoors.
I have 2 beautiful lush plants with no blooms, just leaves!
Can bulbs getting tired or something? They are 2 years old.
Did I do something wrong? Thanks, Buttercup

Poughkeepsie, NY(Zone 6a)

Probably one or both of these, lack of fertilizer (or not enough) and not enough light.

This goes for just about every kind of flowering plant by the way.

How much light does it get and how often do you feed it?

Waterloo, ON(Zone 5a)

You're right- the light is decent but I bet it's the fertilizer. Thanks

Poughkeepsie, NY(Zone 6a)

You are welcome. Also, sometimes you THINK they get enough light but it turns out not to be. Re-evaluate your light level.



This message was edited Nov 16, 2008 8:37 PM

Columbus, OH

I have an Amyryllis Papillio from last year. I gave it some slow release fertilizer after it bloomed and kept it inside on a south facing window until it got warm enough in the spring. I planted it on the west side of my house for about 6 weeks. Then I pulled it and put it loosely in a larger pot in the basement. This fall I found it sprouting a leaf so I potted it up and started watering it on the south facing window again. There are about six leaves right now. Is that normal for the leaves to come out first? I don't see a bloom yet. I am trying to figure out if it will bloom again.

Poughkeepsie, NY(Zone 6a)

You have to wait and let it do it's thing. It'll bloom when it's ready!

Columbus, OH

Oh good! I was starting to get a little worried. It's been growing leaves over a month. I thought I remembered reading that it needed 7 leaves before it would bloom. Thank you for the reassurance, Tommyr2006!

Post a Reply to this Thread

You must log in and subscribe to Dave's Garden to post in this thread.
BACK TO TOP