Non blooming amaryllis

Worcester, MA

I planted two large bulbs almost a month ago. i plant bulbs every winter and never have a problem. These two are just not doing anything. I take that back, one is getting a sprout out of it's side. Anyway, they feel fine, have the soil and pots I always use and the same amount of light. I am really discouraged. Does anyone have any suggestions? I would really like to see some growth before Christmas, as they are gifts. I have another bulb in rocks and water and it is already a foot high with 2 buds. Please help!

(Zone 8a)

Maybe they're just concentrating on growing roots at the moment. I wouldn't worry too much - they will probably take off in a little while.

Houston, TX(Zone 9b)

Ya, my 'Misty' sat there for probably close to a month, if not more than, before I even saw a green tip peak out. I just kept watch on it, not keeping too wet or too dry - just a little damp. Then when the flower stalk emerged it jumped up to nearly 2 feet seemingly overnight! When I saw the active growth start, I watered it a little more freely. Right now (after being in bloom for about an additional month), she's *hopefully* forming seed pods.

Worcester, MA

Still no luck and it's been almost 2 months. it looks fine, the roots are white and fat. I jst don't get it.

Lincoln, NE(Zone 5b)

I have a few doing the same thing. Do you have yours in a fairly warm place? A couple that were slow to start in a cold window took right off when I place them on a low temp heating mat.

Susan

Worcester, MA

I will try that.

Post a Reply to this Thread

You must log in and subscribe to Dave's Garden to post in this thread.
BACK TO TOP